Помогите нужно составить программу,которая формирует массив с 16 случайных целых чисел от -20 до 20 и: находит элементы с нулевыми значениями
Ответы на вопрос
Ответил t0uchdream
0
Не понял смысл задачи.
Написал, вывод номера элементов равных 0.
Написал, вывод номера элементов равных 0.
Приложения:

Ответил Leahance
0
#include <stdio.h>#include<stdlib.h>
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}
int main(void){ int mas[16]; //массив со случайными числами int i; //счетчик
//заполнение массива случайными числами for(i=0; i<16; i++) mas[i] = -20+rand()%20; printf("ishodny massiv"); for(i=0;i<16;i++) printf("%d,",mas[i]); printf("n");
printf("nomera elementov massiva ravnih nulu"); for(i=0;i<16;i++) if (mas[i]==0) printf("%d",i+1);
return 0;}
Приложения:

Новые вопросы
Математика,
2 года назад
Математика,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Математика,
9 лет назад