Информатика, вопрос задал krimov4219 , 7 лет назад

Помогите! Нужно сделать алгоритм в python

Программа получает на вход последовательность целых неотрицательных чисел, каждое число записано в отдельной строке. Последовательность завершается числом 0, при считывании которого программа должна закончить свою работу и вывести количество членов последовательности (не считая завершающего числа 0). Числа, следующие за числом 0, считывать не нужно.

Нужно сделать принудительный выход из цикла, продолжение итерации)

Ответы на вопрос

Ответил korsa351
3

total = 0

while 1 > 0:

   if int(input()) != 0:

       total += 1

   else:

       break

print(total)

Новые вопросы