Информатика, вопрос задал kinguinn , 8 лет назад

Помогите , нужна программа для этих задач:
1)Вводится произвольная последовательность действительных чисел. Вычислить кол-во нечетных чисел в промежутке от 2 до 31
2)Вводится произвольная последовательность целых чисел. Найти произведение элементов кратных 4 и больших нуля.
3)Составить программу для вычисления площади круга и длины диаметра, если радиус постоянная величина и равен 10 см.

Ответы на вопрос

Ответил Ира2308
0
: var a, s, n: integer; begin WriteLn('Введите числа, завершение -- 0:'); n:=0; s:=0; Read(a); while a<>0 do begin if not odd(a) then begin inc(n); s:=s+a; end; Read(a); end; if n>0 then WriteLn('Среднее арифметическое четных: ',s/n) else WriteLn('Четных чисел не введено.'); end. Ну я так поняла первое задание (не точно)
Новые вопросы