ПОМОГИТЕ!!! Необходимо написать программу, которая находит минимальный элемент матрицы и ставит его на место первого элемента матрицы(то есть в левый верхний угол)
gangster7:
На каком языке писать?
Ответы на вопрос
Ответил Puz1koO
0
const N=5;
var a:array [1..N,1..N] of integer;
i,j,min:integer;
begin
randomize;
for i:=1 to N do
begin
for j:=1 to N do
begin
a[i,j]:=random(21)-10;
write(a[i,j]:4);
end;
writeln;
end;
writeln;
min:=a[1,1];
for i:=1 to N do
for j:=1 to N do
if a[i,j]<min then
min:=a[i,j];
if min<>a[1,1] then a[1,1]:=min;
for i:=1 to N do
begin
for j:=1 to N do
write(a[i,j]:4);
writeln;
end;
end.
Новые вопросы
История,
1 год назад
Українська література,
1 год назад
Українська мова,
1 год назад
Литература,
7 лет назад