Помогите!!!!
Напишите программу,которая в последовательности натуральных чисел определяет количество трехзначных чисел,кратных 4.Программа получает на вход натуральные числа,количество введенных чисел,неизвестно,последовательность чисел заканчивается числом 0 (0-признак окончания ввода,не входит в последовательность).Количество чисел не превышает 1000.Введенные числа не превышают 30000.Программа должна вывести одно число:количество трехзначных чисел,кратных 4.
(Паскаль)
Ответы на вопрос
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1411 от 23.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Write(ReadSeqIntegerWhile(k->k<>0).
Where(k->(k>99) and (k<1000) and (k mod 4=0)).Count)
end.
Пример
45 244 1043 463 500 241 18 44 0
2
// Внимание! Если программа не работает, обновите версию!
begin
Write(ReadSeqIntegerWhile(k->k<>0).
Where(k->(k>99) and (k<1000) and (k mod 4=0)).Count)
end.
Пример
45 244 1043 463 500 241 18 44 0
2
Ответил Аноним
0
Var A,k:integer;
Begin
k:=0;
Repeat
Read(A);
if (A>99)and(A<1000)and(A mod 4 = 0) then k:=k+1
Until A = 0;
WriteLn(k);
End.
Begin
k:=0;
Repeat
Read(A);
if (A>99)and(A<1000)and(A mod 4 = 0) then k:=k+1
Until A = 0;
WriteLn(k);
End.
Новые вопросы
Литература,
2 года назад
Английский язык,
2 года назад
Математика,
8 лет назад
Математика,
9 лет назад