Помогите написать программы..
Задача 1
Напишите программу, умеющую проверить положительное ли число, введённое с клавиатуры
Задача 2
Напишите программу в которой из двух введенных с клавиатуры чисел, большее из них выведется на экран
Задача 3
Напишите программу которая при вводе пяти чисел вычисляла бы их сумму и произведение, и выводила на экран, что из этого больше.
Ответы на вопрос
Ответил zarembo73
0
1)
Var x: real;
Begin
writeln ('Введите число');
readln (x);
if x>0 then
writeln ('Число ', x, ' положительное')
else
if x<0 then
writeln ('Число ', x, ' отрицательное')
else
if x=0 then
writeln ('Число ', x, ' не является ни положительным, ни отрицательным');
End.
2.
Var x, y: real;
Begin
writeln ('Введите два числа');
readln (x,y);
if x>y then writeln (x)
else
if x<y then writeln (y)
else
if x=y then writeln ('Числа равны');
End.
3.
Var x, sum, pr: real;
i: integer;
Begin
sum:=0;
pr:=1;
For i:=1 to 5 do
begin
write ('Введите число: ');
readln (x);
sum:=sum+x;
pr:=pr*x;
end;
writeln ('Сумма чисел = ', sum);
writeln ('Произведение чисел = ', pr);
if sum>pr then writeln (sum)
else
if sum<pr then writeln (pr)
else
if sum=pr then writeln ('Сумма и произведение равны');
End.
Var x: real;
Begin
writeln ('Введите число');
readln (x);
if x>0 then
writeln ('Число ', x, ' положительное')
else
if x<0 then
writeln ('Число ', x, ' отрицательное')
else
if x=0 then
writeln ('Число ', x, ' не является ни положительным, ни отрицательным');
End.
2.
Var x, y: real;
Begin
writeln ('Введите два числа');
readln (x,y);
if x>y then writeln (x)
else
if x<y then writeln (y)
else
if x=y then writeln ('Числа равны');
End.
3.
Var x, sum, pr: real;
i: integer;
Begin
sum:=0;
pr:=1;
For i:=1 to 5 do
begin
write ('Введите число: ');
readln (x);
sum:=sum+x;
pr:=pr*x;
end;
writeln ('Сумма чисел = ', sum);
writeln ('Произведение чисел = ', pr);
if sum>pr then writeln (sum)
else
if sum<pr then writeln (pr)
else
if sum=pr then writeln ('Сумма и произведение равны');
End.
Новые вопросы
Английский язык,
2 года назад
Английский язык,
2 года назад
География,
8 лет назад
Литература,
8 лет назад
Математика,
9 лет назад