Информатика, вопрос задал komlikk , 1 год назад

Помогите написать программу вычисления выражения (5а-3)(4-3b)+c
В паскале


komlikk: Лол, мы только начали проходить эту тему,а я болела

Ответы на вопрос

Ответил helloplshelpme
1
var a, b, c: integer;

begin
readln (a, b, c);
writeln ((5*a-3) * (4-3*b) + c);
end.

Поясняю за код:


Первой строкой задаём переменные (аbc) и обозначаем их тип (здесь: integer - целые числа, при необходимости - замени на числа с плавающей точкой);

Второя строчка - для красоты, необязательна;

Третья - начало программы;

Четвертая - считывает с клавиатуры переменные аbc;

Пятая - выводим на экран результат выражения,

Шестая строка - конец.

---Так же можно было задать новую переменную d (что бессмысленно, но, наверное, пока именно этот вариант тебе подойдёт)

var a, b, c, d: integer;

begin
readln (a, b, c);
d:=((5*a-3) * (4-3*b) + c);
writeln(d)
end.
Новые вопросы