Информатика, вопрос задал sergicc293 , 2 года назад

Помогите написать программу в турбо паскале, а именно:
Протабулировать функцию y=x-пи на отрезке [0;11] с шагом h=1,1. Результаты вычислений вывести на экран в виде таблицы пар чисел x, y. Вычислить модуль разности максимального и минимального значений функции y.

Ответы на вопрос

Ответил Аноним
0
uses Crt;
const
  pi=3.14159;
var
  x,y,h,max,min,d:real;
begin
  ClrScr;
  max:=-100; min:=100; x:=0; h:=1.1;
  while x<=11+h/2 do begin
    y:=x-pi;
    Writeln(x:10:7,y:12:7);
    if max<y then max:=y;
    if min>y then min:=y;
    x:=x+h;
  end;
  d:=abs(max-min);
  Writeln(d:10:7);
  ReadKey
end.

Результат выполнения программы:
 0.0000000  -3.1415900
 1.1000000  -2.0415900
 2.2000000  -0.9415900
 3.3000000   0.1584100
 4.4000000   1.2584100
 5.5000000   2.3584100
 6.6000000   3.4584100
 7.7000000   4.5584100
 8.8000000   5.6584100
 9.9000000   6.7584100
11.0000000   7.8584100
11.0000000

Новые вопросы