Информатика, вопрос задал бюрло , 9 лет назад

Помогите написать программу в turbo Pascal. Напишите программу Генератором случайных чисел генерируется последовательность 50-ти случайных чисел из диапазона [-10;20]. Вычислить сумму положительных элементов последовательности, порядковые номера которых нечетны.

Ответы на вопрос

Ответил randomnickname
0
var a : array[1..50] of integer;   
      sum, i : integer;
begin
randomize;
for i := 1 to 50 do begin 
      a[i] := random(31)-10; 
      if (a[i] > 0) and (i mod 2 <> 0) then   
            sum := sum + a[i]; 
end;
write(sum)
end.
Ответил randomnickname
0
var a : array[1..50] of integer;
sum, i : integer;
begin
randomize;
for i := 1 to 50 do begin
a[i] := random(31)-10;
writeln(i,' ',a[i]);
if (a[i] > 0) and (i mod 2 <> 0) then
sum := sum + a[i];
end;
writeln(sum)
end.
Новые вопросы