Помогите написать программу в СИ++.Задача такая : Если сумма трёх попарно различных действительных чисел x,y,z меньше единицы, то наименьшее из этих трёх чисел заменить полусуммой двух других; в противном случае заменить меньшее из x и y полусуммой двух оставшихся значений. Заранее спасибо))
Ответы на вопрос
Ответил Gleb1Kosyrev
0
//Dev-C++ 5.11
#include <iostream>
using namespace std;
int main(void)
{float x,y,z=0;
cin>>x>>y>>z;
if(x+y+z<1)
{float min=x;
if (min>y) min=y;
if (min>z) min=z;
if (min==x) x=(y+z)/2;
if (min==y) y=(x+z)/2;
if (min==z) z=(x+y)/2;}
else
if(x>y) y=(x+z)/2; else x=(y+z)/2;
cout<<x<<" "<<y<<" "<<z<<" ";
return 0;}
Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
#include <iostream>
using namespace std;
int main(void)
{float x,y,z=0;
cin>>x>>y>>z;
if(x+y+z<1)
{float min=x;
if (min>y) min=y;
if (min>z) min=z;
if (min==x) x=(y+z)/2;
if (min==y) y=(x+z)/2;
if (min==z) z=(x+y)/2;}
else
if(x>y) y=(x+z)/2; else x=(y+z)/2;
cout<<x<<" "<<y<<" "<<z<<" ";
return 0;}
Пример ввода:
1.1
2.2
3.3
Пример вывода:
2.75 2.2 3.3
Ответил mirl1
0
а через flag если делать, что нужно заменить?
Ответил Gleb1Kosyrev
0
Без понятия что значит "делать через flag".
Новые вопросы
Математика,
2 года назад
Химия,
2 года назад
Алгебра,
9 лет назад
Биология,
9 лет назад
Геометрия,
9 лет назад