Информатика, вопрос задал nafanyavika32 , 9 лет назад

Помогите написать программу в С++
n=min(x+y,y-z)/max(x,y)

Ответы на вопрос

Ответил petyaGavrikov
0
#include <iostream>
using namespace std;

int main()
{
    double x, y, z, min, max, n;
    cout << "Введите x:", cin >> x, cout << "n";
    cout << "Введите y:", cin >> y, cout << "n";
    cout << "Введите z:", cin >> z, cout << "n";
    if (x+y<y-z) min = x+y;
    else min = y-z;
    if (x>y) max = x; 
else max = y;
n = min/max;
    cout << "n = " << n;
    return 0;
}

Пример:
Введите x: 5
Введите y: 8
Введите z: 3
n = 0.625
Ответил nafanyavika32
0
почему то выбивает ошибку..(( using namespare std; - в этой строчке
Ответил nafanyavika32
0
спасибо.все разобралась дальше сама)
Новые вопросы