Информатика, вопрос задал DiGiLi , 1 год назад

Помогите написать программу в Python

Задан двумерный массив А из 3-х строк и 5-и столбцов. Составить программу, которая организует одномерный массив, каждый элемент которого есть количество положительных элементов исходного массива в столбце. Вычислить произведение элементов полученного массива.

Ответы на вопрос

Ответил mishsvyat
0

Ответ:

Объяснение:

Обозначим заданный двумерный массив через A, искомый одномерный - через В, произведение всех элементов этого массива - M. Тогда:

B=[ ]

M=1

for i in range(5):

   n=0

   for j in range(3):

       if A[ j ][ i ]>0:

           n+=1

   B.append(n)

   M*=n

print(B,M)

Новые вопросы