Информатика, вопрос задал vfvawdasider , 8 лет назад

Помогите написать программу в Python пожалуйста
Программа просит ввести основание и прилегающую высоту треугольника, присваивает введённые значения переменным a и h, вычисляет площадь треугольника и печатает значения a, h и площади треугольника. Вычисление площади треугольника оформлено в виде вспомогательной функции.

Ответы на вопрос

Ответил BrightOne
0
# coding: utf-8
# Python 3.X

'''
Программа просит ввести основание
и прилегающую высоту треугольника,
присваивает введённые значения
переменным a и h, вычисляет площадь
треугольника и печатает значения
a, h и площади треугольника.
Вычисление площади треугольника
оформлено в виде вспомогательной
функции.
'''

def trig_area(a, h):
    a = 0.5 * a * h
    if a.is_integer():
        return int(a)
    else:
        return a

a = int(input('Введите основание: '))
h = int(input('Введите прилегающую высоту: '))
print('nОснование: {}nВысота: {}nПлощадь: {}'.format(a, h, trig_area(a, h)))
Новые вопросы