Информатика, вопрос задал Trorlo , 10 лет назад

Помогите написать программу в паскате  которая должна   находить  большую  цифру числа (числа integer)  большая цифра числа это  например число 53  большая это 5  а в числе 29 большая  9 и тд ХЕЛП

Ответы на вопрос

Ответил Bakalavr
0
program test;
var a,i,z,max:int64;
begin
readln(a);
for i:=1 to Length(InttoStr(a)) do
beginz:=a mod 10;
a:=a div 10;
if max<z then max:=z;
end;
writeln(max);
end.
Новые вопросы