Помогите написать программу в паскали.Дан одномерный массив A[N]. Найти произведение четных чисел и сумму нечетных.
Ответы на вопрос
Ответил HRAshton
0
const
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.
n = 5;
var
a: array [1..n] of byte;
s, k: longint;
b: byte;
begin
k := 1;
for b := 1 to n do
begin
a[b] := random(1, 11);
write(a[b]:3);
end;
writeln();
for b := 1 to n do
if (a[b] mod 2 = 1) then
s := s + a[b]
else
k := k * a[b];
for b := 1 to n do
writeln(s, ' ', k);
end.
Новые вопросы