Информатика, вопрос задал Зонтиупой , 2 года назад

Помогите написать программу в паскале.
Заполните массив из N элементов случайными числами в интервале [1,N] так, чтобы в массив обязательно вошли все числа от 1 до N (постройте случайную перестановку).
Пример:
Массив:
3 2 1 4 5

Ответы на вопрос

Ответил Aillianna
5

//PascalABC.NET версия 3.4.0.1677 от 17.06.18

//Если программа не запускается, то обновите версию

const

   m = 99;

var

   n,i, j: integer;

   A,: Array[1..m] of integer;

begin

   Randomize;

   write('n = ');

   readln(n);

   

   for i := 1 to n do

   begin

       repeat

           j := Random(n) + 1

       until A[j] = 0;

       A[j] := i;

   end;

   

   for i := 1 to n do

       write(A[i]:3);

   writeln;

end.

Новые вопросы