Помогите написать программу в Паскале.
Ввести с клавиатуры 6 произвольных чисел. Вычислить среднее арифметическое тех чисел, которые делятся на 4 и заканчиваются на 5.( Остаток на деление на 10 равен 5).
Ответы на вопрос
Ответил Аноним
1
var i, x, count: integer;
sum: real;
begin
sum := 0;
count := 0;
for i := 1 to 6 do
begin;
writeln('Введите число');
readln(x);
if (x mod 4 = 0) or (x mod 10 = 5) then
begin;
sum := sum + x;
count := count + 1;
end;
end;
writeln(sum/count);
end.
sum: real;
begin
sum := 0;
count := 0;
for i := 1 to 6 do
begin;
writeln('Введите число');
readln(x);
if (x mod 4 = 0) or (x mod 10 = 5) then
begin;
sum := sum + x;
count := count + 1;
end;
end;
writeln(sum/count);
end.
M1LKFORBODY:
Из всех 6 чисел некоторые будут делаться на 4 без остатка, а другие при делении на 10 будут с остатком 5. Но это не обязательно одно и то же число. И проблема основная у меня возникла уже после того, как сумма чисел уже получилась, но вот как после этого найти среднее арифметическое из этой суммы, я не знаю. Ведь из 6 чисел, заданных на клавиатуре, могут подходить только некоторые.
Новые вопросы
Українська мова,
1 год назад
Русский язык,
1 год назад
Алгебра,
2 года назад
Информатика,
7 лет назад