Информатика, вопрос задал divergent23 , 7 лет назад

Помогите написать программу в паскале..

Среди чисел последовательности 1,2,3,4,5,8,13 ...(каждый следующий член последовательности равен сумме двух предыдущих), найдите количество чисел до первого шестизначного

Заранее благодарю за любую помощь

Ответы на вопрос

Ответил lbvf23
0

Var i, x1, x2, x3,m, y:integer;

Begin

X1:=1;x2:=2;i:=0;m:=0;

While i<>6 do begin

X3:=x1+x2;y:=x3;m:=m+1;i:=0;

While x3>0 do begin

I:=i+1;

X3:=x3 div 10;

End;

X1:=x2;x2:=y;write(' ', y) ;

End;

Write('Первое шестизначное число находиться на ',m,' месте') ;

End.

Вроде как-то так

Новые вопросы