помогите написать программу в паскале с помощью оператора выбора(case.. of.. else) :
Напишите программу для вычисления степени введённого с клавиатуры числа. Степень в диапазоне 0 .. 9.
p.s: я начинающий в программировании, поэтому прошу попонятней написать.
Ответы на вопрос
var a,b,c:integer;
begin
writeln('введите число и степень'); {здесь прост программа тебя спрашивает какие числа}
read(a,b); {здесь программа читает их}
case b of {тут выполняется условие типа если b .... и идут сами степени}
0: writeln(1);
1: writeln(a); {здесь что программа выдаст если ты напишешь такую степень}
2: writeln (a*a);
3: writeln (a*a*a);
4: writeln (a*a*a*a);
5: writeln (a*a*a*a*a);
6: writeln (a*a*a*a*a*a);
7: writeln (a*a*a*a*a*a*a);
8: writeln (a*a*a*a*a*a*a*a);
9: writeln (a*a*a*a*a*a*a*a*a);
end;
end.