Помогите написать программу в Паскале ..... Дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.
Ответы на вопрос
Ответил MrMiner1
1
program n_1;
var m,n,n1,n2,n3,n4:integer;
begin
writeln('Введите трехзначное натуральное число: ');
readln(n);
n1:=n mod 10;
n2:=(n mod 100) div 10;
n3:=n div 100;
m:=n1+n2+n3;
writeln('Сумма цифр: ',m);
writeln('Среднее арифметическое: ',m/3:0:5);
m:=100*n1+10*n2+n3;
writeln('В обратном порядке: ',m)
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Русский язык,
2 года назад
Другие предметы,
2 года назад
Геометрия,
7 лет назад