помогите написать программу в паскаль или исправить ошибку в моей программе.
В матрице имеются как положительные так и отрицательные элементы.Если отрицательных элементов больше половины, то значение элементов четных строк удвоить, в противном случае удвоить значения элементов только последнего столбца.
моя программа:
f:text;
begin
assign (f,'informat8.txt');
reset(f);
writeln( 'исходная матрица');
for i:=1 to n do begin
for j:=1 to n do begin
read(F,b[i,j]);
write (b[i,j]:8:2);
end;
writeln;
end;
writeln;
n1:=0;
for i:=1 to n do
for j:=1 to n do
if b[i,j]<0 then
n1:=n1+1;
if n>=round(n/2)
then begin
for i:=1 to n do begin
if not odd(i) then begin
for j:=1 to n do
b[i,j]:=b[i,j]*2;
end;
end;
end;
for i:= 1 to n do
b[i,j]:=b[i,j]*2;
writeln ('результирующая матрица');
for i:= 1 to n do
begin
for j:= 1 to n do
write (b[i,j]:8:2);
write;
end;
writeln('n=',n);
end.
На этот вопрос еще никто не ответил. Напишите свой ответ или воспользуйтесь поиском:
Новые вопросы
Литература,
2 года назад
Қазақ тiлi,
2 года назад
Алгебра,
9 лет назад
Алгебра,
9 лет назад
Математика,
9 лет назад