Информатика, вопрос задал Ad123ad2 , 8 лет назад

Помогите написать программу в паскаль АBC задание:
Напишите программу которая в последовательности натуральных чисел определяет чётное минимальное число. При этом кол-во введённых чисел неизвестно. Но не превышает 1000. Введённые числа не превышают 30000.В последовательности всегда имеется чётное число. Программа должна вывести это одно минимальное чётное число.

Ответы на вопрос

Ответил Аноним
0
Var N,A,Min:integer;
Begin
Min:=30001;
Read(N);
For N:= 1 to N do
    Begin
    Read(A);
    if (A mod 2 = 0)and(A < Min) then Min:=A;
    End;
WriteLn(Min)
End.
Новые вопросы