Информатика, вопрос задал schooly , 8 лет назад

Помогите написать программу в Pascal, пожалуйста
Среди 8 положительных чисел найти такое, которое имеет наибольшую сумму цифр, используя функцию

Ответы на вопрос

Ответил petyaGavrikov
0
var a,i,s,max,amax:integer;
function sum(n:integer):integer;
var s:integer;
begin
s:=0;
while n<>0 do
 begin
 s:=s+n mod 10;
 n:=n div 10;
 end;
sum:=s;
end;
begin
max:=0;
for i:=1 to 8 do
 begin
 write('a = ');
 readln(a);
 s:=sum(a);
 if s>max then begin max:=s; amax:=a; end;
 end;
writeln('В числе ',amax,'  максимальная сумма цифр = ',max);
end.

Пример:
a = 405a = 120
a = 309
a = 671
a = 456
a = 215
a = 751
a =321
В числе 456 максимальная сумма цифр = 15
Новые вопросы