Помогите написать программу в Pascal.Нужно написать программу для нахождения значения выражения:
Приложения:

Ответы на вопрос
Ответил dar290199
0
program ex1;uses crt;var y, x, z, a, c : real;begin readln(a, c); y:= (2 * a - (a / 23)) / (sqrt(1 + (a / 4))); z:= (2 * c - 4 * y + abs(a - y)) / (exp(1) * x + 2 * a * y * a); writeln(y); writeln(z);end.
Приложения:
Ответил Zabkirill
0
Напиши пожалуйста свою версию, буду очень благодарен
Ответил Аноним
0
В смысле, которая будет, в отличии от этой, работать? )))
Ответил Аноним
0
А в формуле для Z - там точно умножить e на х или все же е в степени х ?
Ответил Zabkirill
0
Скорее всего в степени x
Ответил Zabkirill
0
У нас так учительница пишет
Ответил Аноним
0
// PascalABC.NET 3.3.5, сборка 1636 от 10.03.2018
// Внимание! Если программа не работает, обновите версию!
begin
var (a,c,x):=ReadReal3('Введите a,c,x:');
var y:=(2*a-a/23)/Sqrt(1+a/4);
var z:=(2*c-4*y+Abs(a-y))/(Exp(x)+2*a*y*a);
Writeln('Y=',y,', Z=',z)
end.
Пример
Введите a,c,x: 3.5 -0.167 3.11
Y=5.00094509026456, Z=-0.129959221453275
// Внимание! Если программа не работает, обновите версию!
begin
var (a,c,x):=ReadReal3('Введите a,c,x:');
var y:=(2*a-a/23)/Sqrt(1+a/4);
var z:=(2*c-4*y+Abs(a-y))/(Exp(x)+2*a*y*a);
Writeln('Y=',y,', Z=',z)
end.
Пример
Введите a,c,x: 3.5 -0.167 3.11
Y=5.00094509026456, Z=-0.129959221453275
Приложения:
Новые вопросы
Химия,
2 года назад
Право,
2 года назад
Математика,
8 лет назад
Алгебра,
8 лет назад
Математика,
9 лет назад