помогите написать программу: треугольник задан длинами сторон a,b,c.Определите вид треугольника(тупоугольный,прямоугольный,остроугольный)
Ответы на вопрос
Ответил Аноним
0
var a,b,c:real;
begin
writeln ('Введите стороны треугольника');
read (a,b,c);
if ((a + b) > c) and ((a + c) > b) and ((b + c) > a) then
begin
if (sqr(a)+sqr(b)=sqr(c)) then writeln ('Это прямоугольный треугольник');
if (sqr(a)+sqr(b)>sqr(c)) then writeln ('Это остроугольный треугольник');
if (sqr(a)+sqr(b)<sqr(c)) then writeln ('Это тупоугольный треугольник');
end
else writeln ('Такого треугольника не существует');
end.
begin
writeln ('Введите стороны треугольника');
read (a,b,c);
if ((a + b) > c) and ((a + c) > b) and ((b + c) > a) then
begin
if (sqr(a)+sqr(b)=sqr(c)) then writeln ('Это прямоугольный треугольник');
if (sqr(a)+sqr(b)>sqr(c)) then writeln ('Это остроугольный треугольник');
if (sqr(a)+sqr(b)<sqr(c)) then writeln ('Это тупоугольный треугольник');
end
else writeln ('Такого треугольника не существует');
end.
Новые вопросы