Помогите написать программу пожалуйста, первый и второй номер. 35 былов

Ответы на вопрос
Ответ:
1.
var
a, b: integer;
begin
writeln('Введите два числа:');
readln(a, b);
if a + b < 180 then
writeln('Треугольник существует, угол С = ', 180 - a - b)
else
writeln('Треугольник не существует');
end.
2.
var
a, b, c: integer;
begin
writeln('Введите три числа:');
readln(a, b, c);
if (a + b <= c) or (a + c <= b) or (b + c <= a) then
writeln('Треугольник не существует')
else
writeln('Треугольник существует');
end.
3.
var
a, b, c: integer;
begin
readln(a, b, c);
if a < b then
a := b;
if a < c then
a := c;
writeln(a)
end.
Объяснение:
1. Нужно проверить, что сумма двух углов меньше 180 градусов, тогда треугольник существует, и третий угол равен разности 180 и двух углов.
2. Нужно проверить неравенство треугольника для всех трех сторон (сумма двух любых сторон всегда больше третьей стороны). Если хоть один раз оно нарушается - треугольник не существует.
3. Считываем числа. Храним максимум в первой переменной а. Если второе число больше первого - записываем это число в а. Если теперь третье число больше а, то максимум хранится в с, перезапишем его в а. Выводим ответ.