Информатика, вопрос задал satanlovesyou696 , 8 лет назад

Помогите написать программу, пожалуйста.
Напишите программу, которая находит сумму двухзначных нечетных чисел. Последовательность чисел заканчивается числом 0.

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1634 от 14.02.2018
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqIntegerWhile(t->t<>0)
      .Where(t->t.IsOdd and t.InRange(10,99)).Sum.Println
end.
Ответил AnonimusPro
0
Program n1;
var a,sum: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if (a>9) and (a<100) and (a mod 2<>0) then sum:=sum+a;
readln(a);
end;
write(sum);
end.
Новые вопросы