Информатика, вопрос задал Ad123ad2 , 8 лет назад

Помогите написать программу по программированию
Напишите программу которая в последовательности целых чисел определяет количество чисел оканчивающихся на 5 или кратных 3.Программа получает на вход целое числа количество введённых чисел неизвестно последовательность заканчивается числом 0 (0-признак окончание ввода, не входит в последовательность)
Количество чисел не превышает 1000.Введённые числа по модулю не превышают 30000.
Программа должна вывести одно число: количество чисел оканчивающихся на 5 или кратно 3.

Ответы на вопрос

Ответил Аноним
0
Var A,k:integer;
Begin
k:=-1;
Repeat
Read(A);
if (Abs(A) mod 10 = 5)or(A mod 3 = 0) then k:=k+1;
Until A = 0;
Write(k)
End.
Ответил Ad123ad2
0
program n202_6;
var a:array[1..1000] of integer;
Dat,i,k:integer;
begin
k:=-1;
Repeat
begin
write('Введите число ');
Read(i);
if (i mod 3=0)or(i mod 10 = 5)then
Dat:=Dat+1;
Write('Ответ -> ',Dat);
end;
end.
Ответил Ad123ad2
0
где ошибка?
Ответил Аноним
0
Должно быть repeat until, а не repeat begin end;
Ответил Аноним
0
Который ещё и нигде не используется
Новые вопросы