Помогите написать программу по Паскалю,пожалуйста.
Известно, что коды прописных (заглавных) букв латинского алфавита следуют в таблице непрерывно друг за другом. Коды строчных букв латиницы также следуют непрерывно друг за другом на расстоянии 32 символов от прописных (ниже по таблице) .
Если ord('A') = 65, то ord('A')+32 = 97, и это код строчной буквы «а» , то есть chr(ord('A')+32) = 'а'.
Напишите программу, в которой вы вводите прописную букву (только латиницу!) , а получаете ее строчной эквивалент, и наоборот, по строчной букве получаете соответствующую прописную.
Ответы на вопрос
Ответил Аноним
0
var c:char;
begin
readln(c);
if ord(c)<97 then
c:=chr(ord(c)+32)
else c:=chr(ord(c)-32);
writeln(c);
end.
begin
readln(c);
if ord(c)<97 then
c:=chr(ord(c)+32)
else c:=chr(ord(c)-32);
writeln(c);
end.
Новые вопросы
Литература,
2 года назад
География,
2 года назад
Геометрия,
9 лет назад
Математика,
9 лет назад
Математика,
10 лет назад