Информатика, вопрос задал zxsw , 8 лет назад

Помогите написать программу по информатике на паскале.
Создать с клавиатуры массив из трех чисел-первое число от 1 до 25, второе от 26 до 50, третье от 51 до 100. Создать второй массив случайным образом по таким же правилам. Сравнить эти числа и написать сколько совпало

Ответы на вопрос

Ответил petyaGavrikov
0
type mas=array[1..3] of integer;
var a,b:mas;
i,k:integer;
procedure proc(var x:mas);
var i:integer;
begin
x[1]:=random(25)+1;
x[2]:=random(25)+26;
x[3]:=random(50)+51;
for i:=1 to 3 do write(x[i],' ');
writeln;
end;
begin
randomize;
writeln('1-й массив:');
proc(a);
writeln('2-й массив:');
proc(b);
k:=0;
for i:=1 to 3 do
 if a[i]=b[i] then k:=k+1;
writeln('Число совпавших элементов = ',k);
end.

Пример:
1-й массив:
6 29 58
2-й массив:
21 29 63
Число совпавших элементов = 1
Ответил Giammy
0
var a,b:array[1..3] of integer;
begin
a[1]:=Random(26); b[1]:=Random(26);
a[2]:=Random(26)+25; b[2]:=Random(26)+25;
a[3]:=Random(51)+50; b[3]:=Random(51)+50;
writeln(a[1],' ',a[2],' ',a[3]);
writeln(b[1],' ',b[2],' ',b[3]);
if (a[1]=b[1]) and (a[2]=b[2]) and (a[3]=b[3])
then writeln('Совпало 3')
else
if ((a[1]=b[1]) and (a[2]=b[2])) or ((a[2]=b[2]) and (a[3]=b[3])) or ((a[1]=b[1]) and (a[3]=b[3]))
then writeln('Совпало 2')
else
if (a[1]=b[1]) or (a[2]=b[2]) or (a[3]=b[3])
then writeln('Совпало 1')
else writeln('Совпадений нет');
end.

P.S Писал не на компьютере, возможны ошибки, проверьте и в случае если обнаружатся ошибки, напишите мне
Новые вопросы