Информатика, вопрос задал Марьяна24 , 9 лет назад

Помогите написать программу Pascal!
При поступлении в институт абитуриенты получившие "двойку" за первый экзамен,не допускаются до второго. Дан список абитуриентов и их оценки на первом экзамене. Составьте список абитуриентов допущенных ко 2 экзамену.
Дано:
n:=10
Массив А-Фамилии(записываются вручную)-string
Массив B-оценки random(4)+1
Найти: Массив С[j]-string

Ответы на вопрос

Ответил MaxKrivich
0
const n=10;
var a:array [1..n] of string;   
b:array [1..n] of Integer;   
c:array [1..n] of string;   
i,j:Integer;
begin 
Randomize; 
for i:=1 to n do   
readln(a[i]); 
for i:=1 to n do   
b[i]:=random(4)+1; 
for i:=1 to n do   
begin     
if b[i]>2 then     
begin       
c[i]:=a[i];       
write(c[i],'-',b[i],' ');     
end;   
end;   
Readln;
end.
Новые вопросы