Помогите написать программу-найти в массиве из 5 целых чисел номера отрицательных элементов(вывести их на экран), если таких нет, то сообщить об этом
Ответы на вопрос
Ответил CzarAlex
0
#include <iostream>
#include <cstdlib>
#include <ctime>
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int mass[5];
bool op;
printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;
int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %dn", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");
return EXIT_SUCCESS;
}
#include <cstdlib>
#include <ctime>
int main(int argc, char *argv[])
{
system("chcp 1251 >nul");
setlocale(LC_ALL, "Russian");
srand(time(NULL));
int mass[5];
bool op;
printf("Заполнить массив самостоятельно? (1/0): ");
scanf("%d", &op);
for(int i = 0; i < 5; i++){
if(op){
printf("Введите %d-е число: ", i+1),
scanf("%d", &mass[i]);
}else mass[i] = (rand() % 200) - 100;
}
std::cout << std::endl;
int sm = 0;
for(int i = 0; i < 5; i++)
if(mass[i] < 0) printf("%d-й элемент отрицательный: %dn", i+1, mass[i]), sm++;
if(!sm) printf("В массиве нет отрицательных чисел.");
return EXIT_SUCCESS;
}
Ответил Аноним
0
Очередная демонстрация того, что языку С рядом с Паскалем в школьных задачках делать совершенно нечего...
Ответил Аноним
0
Да вопрос не о разрешении или запрете. Это проблема Вашего учителя, если Вы на С пишете, а другие в классе - на Бейсике или Паскале. Он не может вызвать Вас к доске решить задачу - прочие не поймут. Когда он решает задачу на доске - есть шанс, что Вы не поймете.
Ответил Аноним
0
Вопрос в том, что в школе нет ни малейшего смысла массово изучать С/С++ - об этом уже говорилось не раз.
Ответил CzarAlex
0
В таких ситуациях я использую Паскаль, но все же мне ближе Си.
Ответил Аноним
0
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(5,-20,20); a.Println;
var s:=a.Select((x,i)->(x,i)).Where(k->k[0]<0);
if s.Count>0 then s.Select(k->k[1]+1).Println
else Writeln('Отрицательных элементов нет')
end.
Пример
-6 -16 20 7 -19
1 2 5
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(5,-20,20); a.Println;
var s:=a.Select((x,i)->(x,i)).Where(k->k[0]<0);
if s.Count>0 then s.Select(k->k[1]+1).Println
else Writeln('Отрицательных элементов нет')
end.
Пример
-6 -16 20 7 -19
1 2 5
Новые вопросы
Биология,
2 года назад
Русский язык,
2 года назад
Литература,
8 лет назад
Математика,
8 лет назад
История,
9 лет назад
Химия,
9 лет назад