!Помогите написать программу! Найти и вывести на экран элементы массива равного заданному с клавиатуры числу. Элементы массива заданы случайным образом.
Ответы на вопрос
Ответил Puz1koO
0
var
a:array of integer;
i,n:integer;
begin
write('Введите кол-во эл массива: '); readln(n);
setlength(a,n);
for i:=0 to n-1 do
begin
a[i]:=random(21)-10;
write(a[i],' ');
end;
writeln;
write('Введите число: '); readln(n);
for i:=0 to length(a)-1 do
if a[i]=n then writeln('a[',i+1,']=',a[i]);
end.
Если моё решение вам помогло, отметьте его как лучшее. Спасибо! Удачи!
Новые вопросы
Русский язык,
2 года назад
Русский язык,
2 года назад
Окружающий мир,
6 лет назад
Геометрия,
6 лет назад
Математика,
8 лет назад