помогите написать программу на языке Паскаль)
В прямоугольник со сторонами a и b вписан круг. Найти длину окружности.
Ответы на вопрос
Ответил Vitya9797
0
Если ты имел ввиду описанную около пр-ка окружность то вот
program dlinap;
uses crt;
var a,b,diam,dlina : real;
const pi=3.14;
begin
write('Чему равна длина и ширина пр-ка?');
Readln(a,b);
diam:=sqrt(sqr(a)+sqr(b));
dlina:=pi*diam;
Writeln('Длина окружности равна ',dlina);
end.
program dlinap;
uses crt;
var a,b,diam,dlina : real;
const pi=3.14;
begin
write('Чему равна длина и ширина пр-ка?');
Readln(a,b);
diam:=sqrt(sqr(a)+sqr(b));
dlina:=pi*diam;
Writeln('Длина окружности равна ',dlina);
end.
Новые вопросы
Қазақ тiлi,
2 года назад
Геометрия,
2 года назад
Литература,
9 лет назад
Математика,
10 лет назад
Химия,
10 лет назад