Помогите написать программу на языке Паскаль с подпрограммой "procedure"
Задание 5.8
Приложения:

Ответы на вопрос
Ответил smnoregrets
0
Листинг программы и скриншот результат в приложении.
Написано на PascalABC.NET но должно работать и в других Паскалях.
Написано на PascalABC.NET но должно работать и в других Паскалях.
Приложения:

Ответил Аноним
0
// PascalABC.NET 3.3, сборка 1625 от 17.01.2018
// Внимание! Если программа не работает, обновите версию!
procedure mn(a:array of integer; var r:real);
begin
var s:=a.Where(t->t<0);
r:=s.Count>0? s.Average : 0
end;
begin
var x:=ArrRandom(8,-99,99); x.Println;
var y:=ArrRandom(5,-99,99); y.Println;
var z:=ArrRandom(8,-99,99); z.Println;
var x1,y1,z1:real;
mn(x,x1); mn(y,y1); mn(z,z1);
var F:=Sqr(x1)+Sqr(y1)+sqr(z1);
Writeln('F = ',F)
end.
Пример
87 -97 6 6 -58 56 -50 11
84 -74 57 45 44
6 -23 -17 66 14 -26 80 -99
F = 11847.0069444444
Замечание: Пример того, как НЕ НУЖНО использовать процедуры.
// Внимание! Если программа не работает, обновите версию!
procedure mn(a:array of integer; var r:real);
begin
var s:=a.Where(t->t<0);
r:=s.Count>0? s.Average : 0
end;
begin
var x:=ArrRandom(8,-99,99); x.Println;
var y:=ArrRandom(5,-99,99); y.Println;
var z:=ArrRandom(8,-99,99); z.Println;
var x1,y1,z1:real;
mn(x,x1); mn(y,y1); mn(z,z1);
var F:=Sqr(x1)+Sqr(y1)+sqr(z1);
Writeln('F = ',F)
end.
Пример
87 -97 6 6 -58 56 -50 11
84 -74 57 45 44
6 -23 -17 66 14 -26 80 -99
F = 11847.0069444444
Замечание: Пример того, как НЕ НУЖНО использовать процедуры.
Приложения:

Ответил smnoregrets
0
да. надо функцию использовать и динамические массивы.
Новые вопросы
География,
2 года назад
Биология,
2 года назад
Математика,
8 лет назад
Математика,
8 лет назад
Обществознание,
9 лет назад