Информатика, вопрос задал artemh1125 , 2 года назад

ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ НА ЯЗЫКЕ ПАСКАЛЬ!!!
1)Дан текст. Определите количество цифр в нем.
2)Вывести на экран числа в виде следующей таблицы:
41 42 ... 50
51 52 ... 60
61 62 ... 70
71 72 ... 80
3)Дан текст, в котором имеются цифры. Найдите их сумму.
ТЕМА: ВЛОЖЕННЫЕ ЦИКЛЫ​​

Ответы на вопрос

Ответил defendercryak
1

1)

program test1;

var a:string;

i,n,f:integer;

begin

read (a);

n:=length(a);

for i:=1 to n do begin

if (a[i]>='0') and (a[i]<='9')  

 then f:=f+1;

end;

write ('Количество цифр= ',f);

end.

2)

program test1;

var i:integer;

begin

for i:=41 to 50 do

write(i:3);

writeln;

for i:=51 to 60 do

write(i:3);

writeln;

for i:=61 to 70 do

write(i:3);

writeln;

for i:=71 to 80 do

write(i:3);

end.

3)

var s: string;

   i: byte;

   sum,c,k: integer;

begin

sum:=0;

read(s);

for i:=1 to length(s) do

   if s[i] in ['0'..'9'] then

      begin

      val(s[i],c,k);      

      sum:=sum+c;

      end;

writeln('Сумма цифр=',sum);

end.

Новые вопросы