Помогите написать программу на языке C++ с помощью процедур Void...
Напишите процедуру, которая выводит на экран запись переданного ей числа в
римской системе счисления.
Введите натуральное число:
MMXIII
Буду очень благодарен
Ответы на вопрос
Ответил 65biso2
0
Дак это уже было написано тысячу раз...
static void Rom(int N) {
string out="";
string rom[] = { "M", "CM", "D", "CD", "C", "XC", "L", "XL", "X", "IX", "V", "IV", "I" };
int dec[] = { 1000, 900, 500, 400, 100, 90, 50, 40, 10, 9, 5, 4, 1 };
while (N > 0) {
int i = 0;
while (N < dec[i]) i++;
out+=rom[i];
N -= dec[i];
}
cout << out;
}
Новые вопросы
Математика,
7 лет назад
Математика,
9 лет назад