Информатика, вопрос задал Аноним , 2 года назад

помогите написать программу на с++ ( желательно используя цикл while), или напишите хотя бы алгоритм кусочка, который должен быть в цикле:

пользователь вводит натуральное число, программа определяет, верно ли, что в его записи есть 2 одинаковые цифры, стоящие рядом.​

Ответы на вопрос

Ответил pz4t9v0d4tly
1

#include <iostream>

using namespace std;

int main() {

cout << "enter the number: ";

int n = 0;

cin >> n;

string nString;

nString = to_string(n);

for(int i = 0; i<nString.length()-1; ++i) {

if(nString[i]==nString[i+1]) {

cout << "yes";

return 1;

}

}

cout << "no";

return 0;

}

Новые вопросы