Помогите написать программу на с++
Надо вывести из строки со словами разделенными пробелами , вывести слова в которых буквы не повторяются
Ответы на вопрос
Ответил Аноним
0
#include<iostream>
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}
#include<string>
using namespace std;
int main()
{
string S;
cout << "BBEDITE TEXT: ", getline(cin,S);
S+=' ';
string Slovo = "";
for (int i = 0; i < S.length(); i++)
{
if (S[i] != ' ') Slovo+=S[i];
else
{
bool B = 1;
for(int j = 0; j+1 < Slovo.length(); j++)
{
for(int m = j+1; m < Slovo.length(); m++)
{
if (Slovo[j] == Slovo[m]) B = 0;
}
}
if (B) cout<<"n" <<Slovo;
while (S[i] == ' ') i++;
Slovo=S[i];
}
}
return 0;
}
Новые вопросы
Английский язык,
2 года назад
Немецкий язык,
2 года назад
Информатика,
8 лет назад
Физика,
8 лет назад
Математика,
9 лет назад