Информатика, вопрос задал rayman6756757 , 2 года назад

Помогите написать программу на python
Создай базу интересов. Сначала у первого пользователя запрашиваем число интересов, которое он хочет ввести, затем он вводит их и они добавляются в первое множество. Ту же самую операцию проводим для второго пользователя.
Результат работы программы. Программа выводит на экран множество, в котором записаны совпавшие интересы. Если совпадений нет, программа выводит строку ‘Нет общих интересов’.

Приложения:

Ответы на вопрос

Ответил merkkaa
1

interests1 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("Введите кол-во интересов: ")))]

interests2 = [input(f"Введите {i+1} интерес: ") for i in range(int(input("2Введите кол-во интересов: ")))]

general = []

for i in interests1:

   for ii in interests2:

       if i == ii:

           general.append(i)

if len(general) != 0:

   print(f" {len(general)} общих интереса:  {general}")

else:

   print("Нет общих интересов")

Приложения:
Новые вопросы