Информатика, вопрос задал feldman2001 , 7 лет назад

Помогите написать программу на python с использованием множеств и пересечения

Максим едет на автобусе и, чтобы развеять скуку, придумал себе игру. Он смотрит в окно и записывает все номера домов на тетрадный листок. На середине пути он берёт новый листок и продолжает записывать номера. В конце пути он хочет узнать, какие номера встретились ему в обоих списках, и выписывает их на третий листок. Если таких номеров нет, то Максим считает поездку не очень удачной и записывает слово EMPTY.

Формат ввода
На первой строчке через пробел записаны номера с первого листка. На второй строке через пробел — номера со второго листка.

Формат вывода
Номера, встретившиеся на обоих листках в порядке возрастания. Если таких номеров нет, надо вывести слово EMPTY.​

Приложения:

Ответы на вопрос

Ответил budzsergiy777p0i27m
0

def bus():

   leaf_one = []

   leaf_two = []

   while True:

       number_home = input()

       if number_home != 'n':

           leaf_one.append(number_home)

       else:

           break

   print('New leaf')

   while True:

       number_home = input()

       if number_home != 'end':

           leaf_two.append(number_home)

       else:

           break

   c = set(leaf_one)&set(leaf_two)

   if len(c)>=1:

       print(c)

   else:

       print("EMPTY")

bus()

Новые вопросы