Информатика, вопрос задал gluzhina , 6 лет назад

Помогите написать программу на питоне пожалуйста.
Напишите программу, которая вводит два целых числа и находит их произведение, не используя операцию умножения. Учтите, что числа могут быть отрицательными.

Входные данные
Входная строка содержит два целых числа.

Выходные данные
Программа должна вывести произведение введённых чисел.

Примеры
входные данные
6 12
выходные данные
72
входные данные
-7 15
выходные данные
-105

Ответы на вопрос

Ответил MrMaks1096
0

Ответ:

x = int(input("Введите первое число"))

y = int(input("Введите второе число"))

result = 0

z = 0

 

while z != (abs(y)):

   result = result+(abs(x))

   z=z+1

 

if (x<0 and y>0) or (x>0 or x<y):

  result = -result

 

print(result)

Объяснение:

Ответил rootправа
0

Ответ:

Объяснение:

x = int(input())

y = int(input())

res = 0

for k in range(abs(x)):

   res += y

worklist = [x,y]

worklist.sort()

if 0 in range(worklist[0],worklist[1]):

   res = -res

print(res)

Новые вопросы