Информатика, вопрос задал maksimosipov , 9 лет назад

Помогите написать программу на паскале!!!
Выбрать из текста слова в которых первая буква совпадает с последней, слова в тексте разделены пробелами

Ответы на вопрос

Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('Введите текст:');
  Writeln('Слова, в которых совпадают первая и последняя буквы:');
  s.ToWords.Where(x->x[1]=x[x.Length]).Println(NewLine)
end.

Тестовое решение
Введите текст: космос азбука     баобаб  импульс озеро  довод  конец
Слова, в которых совпадают первая и последняя буквы:
азбука
баобаб
озеро
довод
Ответил maksimosipov
0
А на free pascal
Ответил Аноним
0
Не люблю я его, убогий он. Если Вам надо FPC - указывайте это сразу в вопросе.
Ответил Аноним
0
На Фри придется делать распознавание слов в строке. А потом так же, для каждого слова w длины k проверять совпадение w[1]=w[k]
Ответил A1dar
0
StrUtils немного упрощает задачу
Ответил Аноним
0
Я потому и не люблю FPС, что там нужно шаманить с библиотеками.
Ответил A1dar
0
//Free Pascal 2.6.4

uses
  strutils;

var
  s, t: string;
  i: integer;

begin
  write('Введите текст: ');
  readln(s);
  writeln('Найденные слова: ');
  for i := 1 to WordCount(s, StdWordDelims) do
  begin
    t := ExtractWord(i, s, StdWordDelims);
    if t[1] = t[length(t)] then writeln(t);
  end;
  readln;
end.
Ответил Аноним
0
На Ideone.com для fpc пустой вывод даже при указании значения s путем присваивания в теле программы
Ответил A1dar
0
■ Free Pascal IDE Version 1.0.12 [2014/03/06]
■ Compiler Version 2.6.4
■ GDB Version GDB 7.4
■ Using configuration files from: D:FPCbini386-win32
Running "d:fpcbini386-win322.exe "
Введите текст: космос азбука баобаб импульс озеро довод конец
Найденные слова:
азбука
баобаб
озеро
довод
Ответил maksimosipov
0
Спасибо огромное!!!
Новые вопросы