Информатика, вопрос задал glushkov96 , 9 лет назад

Помогите написать программу на паскале!!
Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел.

Ответы на вопрос

Ответил vladcyb
0
program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
  x, y: longint;
  i: byte;
begin
  y := 0;

  assign(f, 'a4');
  reset(f);

  for i := 1 to 28 do
  begin
    read(f, x);
    y := y + x;
  end;

  writeln(y / 28);
  close(f);
end.
Новые вопросы