Помогите написать программу на паскале :)
С помощью процедуры задать матрицу A(N,M) датчиком случайных чисел. Определить номера строки и столбца максимального элемента массива.
Ответы на вопрос
Ответил petyaGavrikov
0
const n=4; m=5;
type ar=array[1..n,1..m] of integer;
procedure p1(var a:ar);
var i,j:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(20)-10;
write(a[i,j]:4);
end;
writeln;
end;
end;
var a:ar; i,j,max,im,jm:integer;
begin
Randomize;
p1(a);
max:=a[1,1]; im:=1; jm:=1;
for i:=1 to n do
for j:=1 to m do
if a[i,j]>max then
begin max:=a[i,j]; im:=i; jm:=j; end;
writeln('max = a[',im,',',jm,'] = ',max);
end.
Пример:
2 -1 -7 0 7
3 7 -7 -7 3
-7 -5 -3 -2 5
9 -4 -4 -7 -7
max = a[4,1] = 9
type ar=array[1..n,1..m] of integer;
procedure p1(var a:ar);
var i,j:integer;
begin
for i:=1 to n do begin
for j:=1 to m do begin
a[i,j]:=random(20)-10;
write(a[i,j]:4);
end;
writeln;
end;
end;
var a:ar; i,j,max,im,jm:integer;
begin
Randomize;
p1(a);
max:=a[1,1]; im:=1; jm:=1;
for i:=1 to n do
for j:=1 to m do
if a[i,j]>max then
begin max:=a[i,j]; im:=i; jm:=j; end;
writeln('max = a[',im,',',jm,'] = ',max);
end.
Пример:
2 -1 -7 0 7
3 7 -7 -7 3
-7 -5 -3 -2 5
9 -4 -4 -7 -7
max = a[4,1] = 9
Новые вопросы