Помогите написать программу на паскале:
Найти количество точек, лежащих в начале координат.
Ответы на вопрос
Ответил Аноним
0
program part1;
type
Point = record
x, y, z: real
end;
var
A, B: Point;
L: real;
begin
write('Введите координаты (x,y,z) точки А: ');
readln(A.x, A.y, A.z);
write('Введите координаты (x,y,z) точки B: ');
readln(B.x, B.y, B.z);
L := sqrt(sqr(B.x - A.x) + sqr(B.y - A.y) + sqr(B.z - A.z));
writeln('Длина отрезка АВ равна ', L:0:4)
end.
Тестовое решение:
Введите координаты (x,y,z) точки А: 3 -2 5
Введите координаты (x,y,z) точки B: -2.6 4 6.2
Длина отрезка АВ равна 8.2946
program part2;
const
k = 20;
type
Point = record
x, y, z: real
end;
var
a: array[1..k] of Point;
i, n: integer;
begin
write('Введите количество точек (1-20): ');
readln(n);
for i:=1 to n do
begin
write('Введите координаты (x,y,z) точки ',i,': ');
readln(a[i].x, a[i].y, a[i].z)
end;
for i:=1 to n do
if (a[i].x=0) and (a[i].y=0) and (a[i].z=0) then
writeln('Точка номер ',i,' лежит в начале координат')
end.
Тестовое решение:
Введите количество точек (1-20): 6
Введите координаты (x,y,z) точки 1: 4 2 -4
Введите координаты (x,y,z) точки 2: 3 0 5
Введите координаты (x,y,z) точки 3: 0 -3 0
Введите координаты (x,y,z) точки 4: 3.5 7 -2
Введите координаты (x,y,z) точки 5: 0 0 0
Введите координаты (x,y,z) точки 6: 2 5 8
Точка номер 5 лежит в начале координат
type
Point = record
x, y, z: real
end;
var
A, B: Point;
L: real;
begin
write('Введите координаты (x,y,z) точки А: ');
readln(A.x, A.y, A.z);
write('Введите координаты (x,y,z) точки B: ');
readln(B.x, B.y, B.z);
L := sqrt(sqr(B.x - A.x) + sqr(B.y - A.y) + sqr(B.z - A.z));
writeln('Длина отрезка АВ равна ', L:0:4)
end.
Тестовое решение:
Введите координаты (x,y,z) точки А: 3 -2 5
Введите координаты (x,y,z) точки B: -2.6 4 6.2
Длина отрезка АВ равна 8.2946
program part2;
const
k = 20;
type
Point = record
x, y, z: real
end;
var
a: array[1..k] of Point;
i, n: integer;
begin
write('Введите количество точек (1-20): ');
readln(n);
for i:=1 to n do
begin
write('Введите координаты (x,y,z) точки ',i,': ');
readln(a[i].x, a[i].y, a[i].z)
end;
for i:=1 to n do
if (a[i].x=0) and (a[i].y=0) and (a[i].z=0) then
writeln('Точка номер ',i,' лежит в начале координат')
end.
Тестовое решение:
Введите количество точек (1-20): 6
Введите координаты (x,y,z) точки 1: 4 2 -4
Введите координаты (x,y,z) точки 2: 3 0 5
Введите координаты (x,y,z) точки 3: 0 -3 0
Введите координаты (x,y,z) точки 4: 3.5 7 -2
Введите координаты (x,y,z) точки 5: 0 0 0
Введите координаты (x,y,z) точки 6: 2 5 8
Точка номер 5 лежит в начале координат
Новые вопросы