Информатика, вопрос задал vala1998 , 10 лет назад

Помогите написать программу на Паскале.
Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.

 



Ответы на вопрос

Ответил Sky09
0
uses crt;
var a,sum:integer;
begin
     sum:=0;
     repeat
           read(a);
           if (a mod 6=0) or (a mod 11=0) then sum:=sum+a;
     until a=0;
     writeln(sum);
end.
Новые вопросы
Алгебра, 10 лет назад