Информатика, вопрос задал Илья135791 , 9 лет назад

Помогите написать программу на паскале.Надо чтобы введенное число оканчивалось на 7.

Ответы на вопрос

Ответил vladmor
0
var a:integer;
begin
repeat
  readln(a);
  if (a - (a div 10)*10) <> 7 then writeln ('неверно');
until (a - (a div 10)*10) = 7;
writeln(a);
end.


Ответил Илья135791
0
спасибо,вот теперь еще все это понять
Ответил Илья135791
0
div это деление нацело?
Ответил vladmor
0
a div 10 - челая часть от деления на 10
Ответил Илья135791
0
спс
Новые вопросы