Помогите написать программу на Паскале
Даны действительные числа x, y. Определить, принадлежит ли точка с координатами (x, y) заштрихованной области.
Приложения:

Ответы на вопрос
Ответил zzhash
0
Если самая окружность относится к заштрихованной области, то наверное вот так. Если нет, то x*x+y*y просто <1, а не <=.
Хотя может и ошибся, я конкретно...
program aaa;
var x,y:real;
begin
write('x?');readln(x);
write('y?');readln(y);
write('Tochka ');
if (((x>=0) and (y>=0)) or ((x<=0) and (y<=0))) and ((x*x+y*y)<=1) then
write('')
else
write('ne ');
writeln('prinadlezhit zashtrihovannoj oblasti');
end.
Новые вопросы