Помогите написать программу на ПАСКАЛЕ:
даны 3 числа в порядке возрастания-стороны треугольника, вывести сообщение «этот треугольник прямоугольный»
ПОМОГИТЕ ПОЖАЛУЙСТА
РЕШАЕТСЯ ПОЛУГОДОВАЯ
46 баллов
Ответы на вопрос
Ответил Horosheffa
0
var a,b,c: integer;
writeln ('введите стороны прямоугольника')
readln(a,b,c);
if a*a+b*b=c*c than writeln ('этот треугольник прямоугольный') else writeln ('этот треугольник не прямоугольный');
end.
Ответил Horosheffa
0
var a,b,c: integer;
begin
writeln ('введите стороны прямоугольника');
readln(a,b,c);
if a*a+b*b=c*c then writeln ('этот треугольник прямоугольный') else writeln ('этот треугольник не прямоугольный');
end.
begin
writeln ('введите стороны прямоугольника');
readln(a,b,c);
if a*a+b*b=c*c then writeln ('этот треугольник прямоугольный') else writeln ('этот треугольник не прямоугольный');
end.
Ответил Horosheffa
0
вот довел полностью до конца
Ответил LikeSmileLJkee
0
label ra,rb;
var a,b,c: integer;
begin
write('Введите сторону a: ');
readln(a);
ra: write('Введите сторону b: ');
readln(b);
if b>a then
begin
rb: write('Введите сторону c: ');
readln(c);
if c>b then begin
if sqr(c)=sqr(a)+sqr(b) then writeln('Этот треугольник - прямоугольный') else writeln('Этот треугольник - не прямоугольный');
end else begin writeln('Введите число больше, чем ',b); goto rb; end;
end else begin writeln('Введите число больше, чем ',a); goto ra; end;
end.
Ответил Horosheffa
0
закинул в паскаль, где-то ошибка
Ответил LikeSmileLJkee
0
Исправил, не хватило begin-end (ох уж этот паскаль)
Ответил Horosheffa
0
Да, понимаю тебя)
Новые вопросы